IBM Support

N6200 series system warning message: NVMEM battery is low on power and should be replaced as soon as practical

Troubleshooting


Problem

On N6200 series systems, when the NVMEM battery reaches the critical low capacity level of 72-hr run-time, the system will initiate a 24-hr shutdown sequence. A temporary workaround is provided with a pointer to battery firmware download and installation information. Service Processor firmware version 1.3 now includes the battery firmware and is the preferred method to install.

Cause

A N6200 series NVMEM battery can end up in a state where it is no longer charging. The run time capacity of the battery will diminish due to the battery's normal slow discharge. As time goes on, the battery's remaining run time, calculated by the Service Processor, will eventually reach the 80 hr Warning Low zone, and 72 hr Critical Low zone. As a result, Data ONTAP will be automatically shutdown the system every 24 hours if no action is taken.

Diagnosing The Problem

To identify a NVMEM battery that is no longer charging, execute the "environment chassis" nodeshell CLI command. If "Bat Run Time" is less than 120 hr (or not "normal"), and "Charger Volt" and "Charger Curr" are both showing 0 as a Current Reading, the battery is not properly charging. Here is an example output from "environment chassis":

                       Current Critical Warning Warning    Critical
Sensor Name    State   Reading      Low     Low    High        High
----------------------------------------------------------------------
Charger Volt   normal     0 mV       --      --    8900 mV     9000 mV
Charger Cycles normal     0 cycles   --      --     250 cycles  251 cycles
Charger Curr   normal     0 mA       --      --    2200 mA     2300 mA
Bat Temp       normal    21 C       -40 C     1 C    70 C        75 C
Bat Run Time   critlow   72 hr       72 hr   80 hr   --          --
Bat Capacity   normal  2816 mA*hr    --      --      --          --

Bat Curr       normal     0 mA       --      --    2048 mA     2304 mA

Resolving The Problem

Releases which have fixed this problem
This technote describes a temporary workaound, however, the battery firmware is now available as a part of Service Processor firmware version 1.3 and is the preferred method to install. See the Service Processor (SP) Firmware for N series Publication Matrix (S7003683) technote for more information on how to obtain and install Service Processor firmware.

For general information about this issue, see Technote N6200 series: Issue with NVMEM battery capacity and FCMTO error condition (S1004007).

Stand-alone battery firmware with a fix for this problem is available for download and installation, see Technote N6200 series critical battery firmware update available that eliminates battery FCMTO error condition (S1004006) for details.

Temporary workaround to reset battery recharge function
  1. If this is an HA system, take over this controller from its partner. Otherwise, halt the controller.
  2. Boot to Maintenance Mode (press Ctrl-C when booting). Select "5" as the maintenance mode boot method.
  3. Issue a "halt" command.
  4. Wait for Data ONTAP boot to loader prompt (Loader>)
  5. From the SP CLI, execute "system sensors show" and verify that these sensors have the following readings: Charger_Volt = 8.200 V, Charger_Curr = 2000, Bat_Curr greater than 0.
    Bat_Run_Time should also start increasing.
    See NOTES (a)
  6. Boot to normal Data ONTAP mode (execute "boot_ontap". It may pause, waiting for giveback).
    See NOTES (b)
  7. If in an HA configuration, perform the giveback from the partner.
 

Note

(a) Retry Steps 2) to 5) if all 3 sensors have 0 reading values.

(b) Data ONTAP may wait for the battery to charge up to the 72 hr run time level before completely booting.


Contact IBM support personnel for assistance, if required.

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Document Information

Modified date:
13 January 2020

UID

ssg1S1003985