IBM SPSS Statistics 20.0 Release Notes

Release notes


Abstract

IBM SPSS Statistics 20.0 Release Notes

Content

Release notes - IBM SPSS Statistics 20.0


IBM® SPSS® Statistics 20.0 is available. Compatibility and other issues are addressed.

Contents

Description

IBM SPSS Statistics is the world’s leading statistical software used to solve business and research problems by means of ad-hoc analysis, hypothesis testing, and predictive analytics. Organizations use IBM SPSS Statistics to understand data, analyze trends, forecast and plan to validate assumptions and drive accurate conclusions.

System requirements and installation

For information on system requirements and installation, see the installation documents.

For information on downloading the product, see the Download Document.

Known issues

At time of publication, the following issues were known.

Installation

Problem: SPSS Collaboration and Deployment Services Repository dialogs may not work on Mac OS X 10.5 running on 32-bit only hardware.
Solution: See Java runtime for Mac OS X 10.5, 32–bit only

Problem: Export to Microsoft® Office PowerPoint may fail to create the exported file.
Solution: Close down your applications and reboot the system, or ask the administrator of your system to reboot it.

Problem: On Linux®, the silent install may fail to use some of the properties that you have set.
Solution: After the installation completes, use a text editor to edit spssprod.inf in the installation folder, and set the property to the correct value.

Problem: After installing on a Brazilian Portuguese system, output may appear in English.
Solution: From the Edit menu select Options. Click the General tab, and in the Output group, select "Portuguese (Brazilian)" as the Language.

Problem: On Mac OS, the application may not start correctly if you install it into a target directory that contains extended ASCII characters.
Solution: Install to a target directory that contains only 7-bit ASCII characters, for example the default directory.

Problem: Cannot find my authorization code.
Solution: Your authorization code is available from http://www.ibm.com/software/getspss.

Problem: The Network License Administrator Guide includes incorrect instructions for manually configuring redundant license manager servers on Mac OS.
Solution: The correct way to manually configure redundant license managers on Mac OS is to update the statsenv.sh script file and the spssprod.inf file. See Updating statsenv.sh and spssprod.inf for Mac OS

Problem: When you attempt to run the application on a system running Citrix Presentation Server 4.5, Xenapp 5 or 6, and EdgeSight 5.3, the application may fail to start.
Solution: You can resolve the problem by disabling EdgeSight if that is a viable option at your site. The problem has been reported to Citrix and the IBM Java team.

Accessibility

Problem: SPSS Statistics running on 64-bit Windows does not support Freedom Scientific's JAWS screen-reading software.
Solution: You will need a machine with 32–bit Windows to use JAWS with SPSS Statistics.

Problem: JAWS (screen reader) may be very slow with large datasets.
Solution: None. Use smaller datasets when possible. We have reported the problem to Freedom Scientific, the developer of JAWS .

Data Access and Data Editor

Problem: IBM SPSS Statistics may not be able to read data files with specific character encodings when running in distributed mode or with the IBM SPSS Statistics Batch Facility on a UNIX® or Linux server.
Solution: IBM SPSS Statistics on UNIX and Linux relies on iconv to convert character encodings. An older version of iconv may be installed on the server and may not support the encoding of the data file. Upgrade iconv to version 2.4 or higher on the server. If you can't upgrade iconv, configure the IBM Statistics Server to use a different encoding. For more information about configuring the encoding for the SPSS Statistics Server, refer to "Setting a Locale" in the IBM SPSS Statistics Server Administrator's Guide.

Problem: Database wizard may fail when reading Sybase IQ database when running in distributed mode on a UNIX server in Unicode mode.
Solution: If the database source contains a single character set, turn off Unicode mode (select Edit>Options>General>Locale's writing system or run the command SET UNICODE OFF in a command syntax window). If the database source contains multiple character sets, use the GET DATA /TYPE=ODBC command to write the SQL query.

Problem: The Database Wizard "Next" button may not work if your data source is a Teradata driver from the IBM SPSS Data Access Pack.
Solution: Use a native Teradata driver as your data source, or use the GET DATA /TYPE=ODBC command to write the SQL query.

Problem: With some combinations of numeric and blank cells in a column in an Excel XLSX file, some non-zero values may be read as zeros when you open the file.
Solution: Copy the data in Excel and use Paste Special>Values to paste the data into a new Excel file. Then read the new Excel file into SPSS Statistics.

Statistical procedures

Problem: Stopping the Exact Tests feature while in distributed mode and connected to an SPSS Statistics Server running on Linux may abruptly end your session.
Solution: Do not select Stop Processor on the File menu while you are running Exact Tests with SPSS Statistics Server running on Linux. Please wait for Exact Tests to finish.

Problem: Boxplots from Nonparametric Tests (NPTESTS) may have different outliers/extremes than boxplots from other procedures.
Solution: None. NPTESTS boxplots are computed using a weighted averages. Boxplots from other procedures are computed using Tukey's hinges.

Graphics

Problem: When running the application in Portuguese (Brazilian) and using the Graphboard Template Chooser, some requests to create charts may fail.
Solution: Use Edit->Options to temporarily change the user interface language to a different language.

Other

Problem: On Mac OS X Lion when creating legacy tables, OMS commands may fail to run when destination format is SPV, SPW, DOC, XLS or PDF.
Solution: From the Edit menu select Options. Click the Pivot Tables tab, and in the Table Rendering group, de-select "Render as legacy tables".

Problem: On Mac OS when you start the application, you may see a warning about accepting incoming network connections.
Solution: This message is from the built-in system firewall. You can avoid the warning by following the instructions in the message. Note that all communication within the application is local.

Problem: When you export to Microsoft Office 2010 PowerPoint, exported images are compressed and don't display correctly.
Solution: You can disable the compression of images in PowerPoint by creating a new Windows Registry key. An example of how to do this can be found on http://www.technospot.net/blogs/how-to-disable-image-compression-in-power-point-2007/.

Problem:You may get an error when writing files directly to the My Documents folder on Windows Vista and Windows 7.
Solution: When you use SPSS Statistics to write files directly to the My Documents folder (for example, when exporting output to PowerPoint), you may get an error. To correct the problem, write the file to another location. Note that you can write the file to a subfolder in the My Documents folder.

Problem: While in distributed mode and connected to an SPSS Statistics Server running on HP-UX or Solaris, you cannot connect to IBM SPSS Collaboration and Deployment Services using a single sign-on provider.

Problem: When you launch the online help, the Help Contents pane may be blank.
Solution: Refresh the browser display by pressing Ctrl+R (Windows and Linux) or Command+R (Mac OS).

Java runtime for Mac OS X 10.5, 32–bit only

When running on Mac OS X 10.5 on a 32-bit only system, the only Java runtime environment Apple provides is Java 1.5. To access IBM SPSS Collaboration and Deployment Services repositories from these systems, one will need to download a file "activation.jar" from Oracle.com and replace the version that is installed with IBM SPSS Statistics 20.

To check whether a system is 32-bit only, from the Finder select the Apple menu > About This Mac. If the value for Processor says "Intel Core Duo" or "Intel Core Solo", the machine is 32-bit only. Note that "Intel Core 2 Duo" is a 64-bit capable processor and this note does not apply.

Step 1: Download JavaBeans Activation Framework (JAF) 1.0.2 ("activation.jar") from Oracle.

  • Go to this URL: http://www.oracle.com/technetwork/java/jaf102-139581.html.
  • Click on the "Download" button on the page and download the zip file.
  • In the Finder, check your browser's downloads folder for "jaf-1_0_2-upd2.zip",
  • Unzip it if needed (usually on Mac OS X you only need to double click on a Zip file to unzip it).
  • Look for a folder named "jaf-1.0.2", and note the file activation.jar in that folder.

Step 2: Replace the existing SPSS Statistics 20 copy of activation.jar with the version downloaded from Oracle.
  • In the Finder, navigate to the folder in which IBM SPSS Statistics 20 is installed.
  • Ctrl-click on the SPSS Statistics application and from the context menu select "Show Package Contents".
  • In the new Finder window that is displayed, click on the "Contents" folder, then click "bin".
  • Drag the file activation.jar (the downloaded version from Oracle) into the bin folder. When prompted that a newer activation.jar already exists in this location, click on the "Replace" button.
  • SPSS Statistics 20 is now capable of accessing IBM SPSS Collaboration and Deployment Services repositories.
Updating statsenv.sh and spssprod.inf for Mac OS

The Network License Administrator Guide includes incorrect instructions for manually configuring redundant license manager servers on Mac OS. The correct instructions are:

  • Open <installation folder>/SPSSStatistics.app/Contents/MacOS/statsenv.sh in a text editor.
  • Add a line to set the value of the LSHOST environment variable to the names of redundant license manager servers, using a colon to separate each name.For example, if the license manager computers are SERVER1, SERVER2, and SERVER3, this line should look like the following (be sure to include export):
    export LSHOST=SERVER1:SERVER2:SERVER3
  • Save statsevn.sh.
  • Open installation folder/SPSSStatistics.app/Contents/bin/spssprod.inf in a text editor.
  • Set DaemonHost to a blank value: DaemonHost=
  • If a line for RedundantHosts does not exist, add one.
  • Set the value of RedundantHosts to the names of redundant license manager servers, using a colon to separate each name. For example, if the license manager computers are SERVER1, SERVER2, and SERVER3, this line should look like the following:
    RedundantHosts=SERVER1:SERVER2:SERVER3
  • Save spssprod.inf.
  • Restart SPSS Statistics.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

SPSS Statistics

Software version:

20.0

Operating system(s):

AIX, HP-UX, Linux, Mac OS, Solaris, Windows

Reference #:

7021825

Modified date:

2011-08-16

Translate my page

Machine Translation

Content navigation