IBM Support

RequisiteWeb does not work with Word 2007 or Word 2010 on Vista and Windows Server 2008

Troubleshooting


Problem

IBM® Rational® RequisitePro® client for Web (RequisiteWeb) users receive COM errors when working with documents in Microsoft® Word 2007 or Microsoft® Word 2010 on Microsoft Windows Vista® and Windows Server® 2008.

Symptom

The full error message has the following form:

Unable to generate the HTML document:com.rational.rjcb.ComException: HRESULT=0x80044e2d: RqWebDoc.Application.GenerateHTMLDoc: Error updating RequisitePro document into HTML.
Error creating HTML document.
A file error has occurred. (C:\PROGRA~1\Rational\...\Glossary.html)

Document path names:
Source directory:C:\Program Files\Rational\RequisitePro\samples\Learning_Project-Traditional\
Temp directory:C:\PROGRA~1\Rational\common\rwp\EmbeddedExpress\profiles\profile2\installedApps\DefaultNode\ReqWeb.ear\ReqWeb.war\GenDoc\{10C2D0CE-84CF-4C80-9166-E5A849FC821B}\
Destination directory:C:\PROGRA~1\Rational\common\rwp\EmbeddedExpress\profiles\profile2\installedApps\DefaultNode\ReqWeb.ear\ReqWeb.war\GenDoc
Destination HTML path:/ReqWeb/GenDoc/{10C2D0CE-84CF-4C80-9166-E5A849FC821B}/Glossary.html  

Cause

RequisiteWeb uses DCOM to start Word.

Resolving The Problem

To resolve this issue, the system administrator needs to be the user running the Word Services.

Steps for 32-bit environments

  1. Click Start and type dcomcnfg in the Start Search text box. When prompted by Windows permissions, click Continue.
  2. Expand Component Services > My Computer > DCOM Config.
  3. Right-Click Microsoft Office Word 97-2003 and select Properties from the menu.
  4. From the Properties window, click on the Identity tab.
  5. Select the This User radio button and enter Administrator and the password for the Administrator account. Repeat that password in the Confirm Password field. Click OK.
  6. Close the Component Services window. The Word integration now will work correctly in RequisiteWeb.

Steps for 64-bit environments
  1. Go to this path C:\Windows\SysWOW64\ and open the file comexp.msc
  2. Expand Component Services > My Computer > DCOM Config.
  3. Right-Click Microsoft Office Word 97-2003 and select Properties from the menu.
  4. From the Properties window, click on the Identity tab.
  5. Select the This User radio button and enter Administrator and the password for the Administrator account. Repeat that password in the Confirm Password field. Click OK.
  6. Close the Component Services window. The Word integration now will work correctly in RequisiteWeb.

Please note that RequisitePro client for Windows does not require these steps to work with the integration, it works out of the box, however in Microsoft Windows Vista and Microsoft Windows Server 2008 following these steps for Web client will prevent the Word integration to work with RequisitePro client for Windows.

[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Word Integration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.1;7.1;7.1.0.1;7.1.0.2;7.1.1;7.1.1.1;7.1.1.2;7.1.1.3;7.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21266463