IBM Support

In a multi-product scenario, after uninstalling Rational ClearCase, ClearQuest, or RequisitePro web features from a WAS profile, the existing WAS profile might not be started.

Troubleshooting


Problem

After uninstalling IBM Rational ClearCase, Rational ClearQuest, or Rational RequisitePro web components from an existing IBM WebSphere Application Server (WAS) profile, the existing WAS profile might not be restarted and as a result, Web components of installed products that use this profile cannot be used because the profile is stopped.

Symptom

Multiple IBM Rational ClearCase, ClearQuest, or RequisitePro web features are installed and running in the same WebSphere Application Server profile. After uninstalling one of the products, attempts to open a web application for the remaining installed products fail. Here are example scenarios:

  • ClearQuest Web is not running after removing the CCRC WAN Server from a WAS profile <AppSrv01>, where both CCRC WAN Server and ClearQuest Web were installed.
  • ReqWeb is not running after removing ClearQuest Web from a WAS profile <AppSrv01>, where both ReqWeb and ClearQuest Web were installed.
  • CCRC WAN Server is not running after removing ClearQuest Web from an existing WAS profile <AppSrv01>, where both CCRC WAN Server and ClearQuest Web were installed.

Cause

During the product uninstall process, the existing WAS profile must be stopped. After the uninstall operation completes, the profile is not restarted because the product is no longer on the machine. The uninstall process does not provide a way to keep the profile running, or to restart it if other Rational products are still installed in the profile.

Diagnosing The Problem

After an uninstall operation, the existing WAS profile administrative console is stopped.

You can verify this from the Administrative Console, which can be accessed on a web browser on the www.hostname:<WAS_Profile_Port>/ibm/console


<WAS_Profile_Port> can be found under the <WAS_Profile_Location>\logs\AboutThisProfile.txt

Look for the Administrative console port. The default port for AppSrv01 is 9060. For example:
www.localhost:9060/ibm/console.

Resolving The Problem

After uninstalling a product in multi-product installation, restart the WAS profile by using either the startServer command or the Windows Services.


Starting the WAS profile using the startServer command

    1. Change directories to the profile_root/bin</code>] directory of the existing WAS profile.
    2. Start the server with the startServer command.

    • startServer.bat server1 -profileName profile_name

      [Linux] [HP-UX] [Solaris] [AIX]


      startServer.sh server1 -profileName profile_name

      Note:  If you have already changed to the profile_root/bin directory of the target profile, do not specify the -profileName argument.

Starting the WAS profile from the Windows Services console


[Windows] If a Windows service has been created for the application server, optionally use the Windows Services utility to start the server.

    1. To start the Services utility, click Start > Settings Control Panel to open the Control Panel.
    2. From the Control Panel, double-click the Administrative Tools icon to open the Administrative tools folder.
    3. Double-click the Services icon to open the Services console.
    4. In the details panel, locate the existing WAS profile <IBM WebSphere Application Server V7.0 - profileNode>. Then, start the profile using either of these methods:
      1. Click the service. Then, click Start from the Action menu.
      2. Right-click the service. Then click Start.

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Document Information

Modified date:
30 November 2020

UID

swg21517154