How do I save the multiple response sets I've defined through the menu Analyze - Multiple Response - Define Variable Sets?

Technote (FAQ)


I've defined a number of multiple response sets in the menu Analyze - Multiple Response - Define Variable Sets in IBM SPSS Statistics. After that I saved my data file. When I opened the data file up again, my multiple response sets had disappeared. How do I save the multiple response sets from session to session?


The multiple response sets that are defined through Analyze - Multiple Response - Define Variable Sets only exist for as long as that current session of IBM SPSS Statistics is open. When you run a multiple response frequency or crosstabs, the set is actually created within the syntax for that table, and the set only exists while that syntax is run.
The menu provides a convenient graphical interface to associate variables into sets, but the program actually recreates each set every time the multiple response frequency or crosstab is run.

However, if you have the Custom Tables Module (Analyze - Tables - Custom Tables dialog), the sets that are created through those dialog boxes are saved from session to session, as long as you save the data file in which the sets were created.

If you do not have the Custom Tables module, or wish to continue using the Analyze - Multiple Response option, the only way to "save" the multiple response set is to save the syntax that creates the multiple response table. Create the multiple response sets as you normally would, and then set up your multiple response table. Instead of clicking on OK, click on paste. The table will not run, but the syntax that will create the table will be pasted into a syntax file. For example, the following syntax creates a crosstab table of the multiple response variable called health and a variable called sex:

GROUPS=$health (hlth1 hlth2 hlth3 hlth4 hlth5 (1))
/VARIABLES=sex(1 2)
/TABLES=$health BY sex

The groups subcommand actually defines the multiple response set, (in this case, a multiple dichotomy set), the variables subcommand define which regular variables are to be used in the crosstab, as well as their ranges. The table subcommand creates the table, where $health is the multiple response set we created on the groups command and sex is the regular table. You can save this syntax by going to File->Save and giving the syntax file a name.

Now, let's say the next day you wanted to run another multiple response crosstab, using the same multiple response set, but with another variable, such as race. Open your dataset as usual, and then go to File->Open. Select Syntax as your file type, and open up the syntax file you saved previously. You would modify the above syntax and end up with the following:

GROUPS=$health (hlth1 hlth2 hlth3 hlth4 hlth5 (1))
/VARIABLES=race(1 3)
/TABLES=$health BY race

I kept the GROUPS subcommand the same, and the same set is created again. However, I changed the variables designation to race, and changed the range to reflect the range of my race variable. Then, I replaced sex with race on the tables subcommand. Now highlight the syntax, and go to Run->Selection. In the output window, you should see a crosstab, using the same multiple response set, but with race rather than sex.

Remember, the multiple response set only lasts as long with the syntax that creates it and uses it. If you want to use the multiple response set again, the multiple response groups syntax has to be run again, and the variables and tables subcommand changed as needed. These sets will also not show up under Multiple Response->Define Sets, unless you redefine them through the menus

Historical Number


Document information

More support for:

SPSS Statistics

Software version:

Not Applicable

Operating system(s):

Platform Independent

Reference #:


Modified date:


Translate my page

Content navigation