IBM Support

Oracle driver problem when importing data to TM1 from an Oracle Instant Client via ODBC on Red Hat Linux 5.3 and Red Hat Enterprise Linux 4.6.

Troubleshooting


Problem

Cannot import data from Oracle Instant Client via ODBC into TM1 Linux.

Symptom

TM1 server hangs during import.

Cause

Due to a problem in the UNIX ODBC driver (version 2.3.0) with the Oracle Instant Client (version 11.2.0.1.0), the TM1 server hangs when attempting to import data from an Oracle data source via ODBC on Red Hat Linux 5.3 (x86-64) and Red Hat Enterprise Linux 4.6 (x86-64).

Environment

UNIX ODBC driver (version 2.3.0) with the Oracle Instant Client (version 11.2.0.1.0)
Red Hat Linux 5.3 (x86-64) and
Red Hat Enterprise Linux 4.6 (x86-64)

Diagnosing The Problem

On Red Hat Linux when using the SQLFetchScroll ODBC method to fetch rows of data from an Oracle database, the Oracle ODBC 11gR2 driver corrupts heap memory and causes the TM1 server to hang. The Oracle ODBC 64-bit driver version is 11.2.0.1.0.

This problem has been logged with Oracle.

Resolving The Problem

There are two options available to work around this problem:

1. Use an alternative ODBC driver on Red Hat Linux.
This issue does not affect the DataDirect wired driver for Oracle.

Or

2. Add the following line to the TM1 server configuration file tm1s.cfg:

UseSQLExtendedFetch=T

The system may crash if you attempt to connect using UNIX ODBC driver version 2.3.0 without adding UseSQLExtendedFetch=T to the tm1s.cfg.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"9.5.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21455342