IBM Support

"Content within this application coming from the website listed below is being blocked by Internet Explorer Enhanced Security Configuration" when running Standard Reports

Troubleshooting


Problem

User launches any 'standard report' (also known as 'system report'). User receives popup message from Internet Explorer. After clicking 'close' the report tries to run, but does not complete.

Symptom


Internet Explorer
Content within this application coming from the website listed below is being blocked by Internet Explorer Enhanced Security Configuration.
about:security:CCR.exe
Learn more about Internet Explorer's Enhanced Security Configuration...
If you trust this website, you can lower security settings for the site by adding it to the Trusted sites zone....
<...>

After clicking 'close':

Company Structure Reports (Preview)
Please wait, loading the report...

Cause

There are several potential causes for similar symptoms.
  • For more examples, see separate IBM Technote #415889.

This Technote specifically relates to the scenario where the cause is that the Controller client is being run on a system running a version of Windows which includes Microsoft Internet Explorer Enhanced Security Configuration (MS IEESC):
  • MS IEESC is blocking access to the required Report Server website/components.

Environment

Controller client running on a Windows server.
  • Typically this means that the customer is deploying Controller via Citrix (or Microsoft Terminal Server / Remote Desktop)

Diagnosing The Problem

NOTE: In some rare cases, the server may appear to have IEESC already disabled, but in fact it is not.
  • For example, see links (to third-party/non-IBM websites) in Technote 1339302
This means that it is possible to be suffering from this problem even though Microsoft Windows is reporting that IEESC is already disabled!
  • Therefore you should not always trust the following screen to be accurate!
image 2241

Resolving The Problem

Fix

Disable Microsoft Internet Explorer Enhanced Security Configuration (MS IEESC) entirely (on the Citrix/Terminal server).

    

Steps:

The following steps are based on Windows 2012 R2. They may need to be modified slightly for different Windows versions.
1. Ensure no users on the Terminal Server
2. Logon to the Terminal Server as an administrator
3. Right-click on 'Start' and choose 'Run'
4. Type the following: ServerManager
4. In the top left of the left-hand Window, click "Local Server"
5. In the right-hand Window, next to "IE Enhanced Security Configuration" click on the 'On' item:


6. (Optional) Inside the section "Administrators", modify the option to 'Off'

7. Important: Inside the section "Users" modify the option to 'Off':

9. Click "OK"
10. Reboot server.
 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
IMPORTANT: It has been seen several times that the problem can occur even if the current settings are both 'Off'. In this scenario, the solution is to toggle the configuration by performing the following steps:
1. First enable Microsoft Internet Explorer Enhanced Security Configuration (MS IEEC)
image 2244
2. Afterwards, disable MS IEEC
image 2243
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

   

Workaround (More complicated)

Bypass MSIEEC by:

1. Add the Controller Report Server's website to the 'trusted zone' (for the end users)

  • For instructions, see separate Technote #1984087.

2. Afterwards, also add the following website: about:security_CCR.exe

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
03 February 2020

UID

swg21446816