Troubleshooting
Problem
Launching Architect/Perspectives and creating a process to import data from Oracle using the Oracle 11g client causes a TM1 server crash. Running an existing process after upgrading to Oracle 11g can also cause a crash.
Symptom
TM1 server crash with no error message.
Cause
According to our developers, the crash is occurring in the Oracle driver. There is a possibility that this is Oracle Bug 9578533. You can get more details by searching for the following on the Oracle website:
ACCESS VIOLATION IN SQLFETCHSCROLL USING 11.2.0.1 ODBC
The bug appears to be filed against Windows, but affects all platforms. This bug is currently in development with Oracle. We do not have an ETA from Oracle on this fix.
This defect has been logged against Oracle using Oracle support website:
SR #3-1955509251: ODBC client crash
Environment
Windows 2003 or 2008, Oracle 11g
Diagnosing The Problem
Launch Architect and create a process to import data from Oracle. Select ODBC and point to the ODBC connection. Click Preview and data to be imported is visible in the preview pane. If the Variables tab is clicked an empty dialog box with only an OK button appears. When the OK button is clicked the variables tab is empty. Clicking back into the first tab, the dialog box again appears.
Upon checking services it will likely be clear that the TM1 server has crashed.
Resolving The Problem
As a workaround, try adding ONE of the following parameters to your tm1s.cfg file and restart your TM1Server and see if that resolves it for you:
UseSQLExtendedFetch=T
-- or --
UseSQLFetch=T
This workaround tells the TM1 Server to use an alternate API and avoid the broken API in the Oracle driver.
Another alternative would be to use the 10g Oracle client/drivers.
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Document Information
Modified date:
15 June 2018
UID
swg21440596