IBM Support

Generic Service fails with error 406 in system event log

Troubleshooting


Problem

After a failover occurs, the system event log will generate errors stating that the generic service failed.

Symptom

The only symptoms seen are two errors in the system event log. Tivoli Storage Manager still functions correctly and cluster backups run successfully.

Cause

The generic service and volume dependency configuration are not set up.

Environment

Windows

Diagnosing The Problem

Search the system event log for the following messages:
Event ID 1042: Generic Service <name> failed with error 406.
Event ID 1069: Cluster resource <name> in clustered service or application <cluster> failed.

The Tivoli Storage Manager error code 406 indicates that the options file cannot be found.
If the volume that contains the options file is not dependent on the cad or scheduler service, then when a failover occurs, the cad/scheduler may not be able to locate the options file resulting in the errors in the system event log. If the backups are still working correctly, this is a timing issue and no errors are seen in the dsmerror.log.

Resolving The Problem

To resolve the error, the volume with the options file needs to be added as a dependency to the generic service.

The example below is the Failover Cluster on Windows 2008. The generic service is "TSM Cluster CAD". The volume with the options file is Cluster Disk 2. Right click on the generic service and choose Properties. Click on the Dependencies tab and add the cluster disk with the options file to the list. Repeat same procedure on all nodes in the cluster environment.


[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21422032