Unable to log in: Index does not match the table. Delete the index file and re-create the index.

Technote (troubleshooting)


Problem(Abstract)

User launches Consolidator. User receives error message. If user clicks OK, a second error may appear.
All users affected. No user can logon to Consolidator.

Symptom

Error #1

Index does not match the table. Delete the index file
and re-create the index. Method: COPENDB.OPENTABLE

Error #2
Frango
File 'X:\FRANGO\LIVE\data\xlock.dbf' does not exist.
Method: COPENDB.OPENTABLE
[OK] [Canel]

Cause

Invalid (or missing) data (DBF) and/or index (CDX) files.


This may have been caused by a system crash (e.g. network problem or file server crash) prior to the problem occurring.


Resolving the problem

IMPORTANT: Before continuing, as a precaution make sure that there is a recent backup of the Consolidator database. This is in case it is necessary to restore that version of the database (if the following steps fail).


Suggestion (1) - Copy known 'good' files from recent backup of Consolidator (FoxPro) database
If the table is identified (e.g. in the above example it is xlock.dbf) and you are using FoxPro (not SQL) as your database, then it may be possible to copy the .dbf and .cdx files from the "data" folder of a 'good' database backup into the 'bad' database's "data" folder

  • Afterwards, optimise the database (as usual).
This is a fastest/easiest solution to try. If the problem remains, then try suggestion (2).

Suggestion (2) - Delete and re-create all the index (CDX) files
In Windows Explorer move all CDX files out of the Frango 'Data' folder. Re-launch Consolidator. Typically, this will automatically launch a database optimisation which will re-create all the FoxPro database index (*.CDX) files.
  • If this process fails, perform an 'external' database optimisation, by re-launching Consolidator from a shortcut which includes an extra '/O ' switch at the end of the command line.

Steps:
Suggestion (2) - Delete and re-create all the index (CDX) files
  1. Ensure that no users are using Consolidator - Launch Windows explorer, and browse to the location of your database (for example X:\FRANGO\LIVE)
  2. As a precaution, backup the FoxPro database to a 'safe' location. TIP: For example, copy the folder 'X:\FRANGO\LIVE' to 'Z:\backups\frango\LIVE'
  3. Launch Windows Explorer, and open the 'data' folder (for example X:\FRANGO\LIVE\DATA)
  4. Click on the column 'type' (to sort the files by 'type')
  5. Highlight/select all the files that end in CDX (*.cdx)
  6. Right-click, and choose 'delete' (to delete all these *.CDX files)
  7. Re-launch Consolidator. You will receive a series of error messages, which you will need to acknowledge:'Structural .CDX file is not found' - Click 'OK'
  8. 'Alias 'XFRANGO' is not found' - Click 'OK'
  9. 'Open...' - Click 'Cancel'
  10. 'No table is open...' - Click'OK' 'Alias 'XFRANGO' is not found' - Click 'OK'- Click 'OK'- Click 'OK'- Click 'OK'
  11. Consolidator will now Exit
  12. Re-launch Consolidator
  13. You will receive a message: 'Error - The optimization program will be started - Cause: The compulsary index file is missing for the system table - XAK' 'OK'
  14. In the 'Optimise' screen, tick 'Sort Tables' and also Tick 'Include period tables'
  15. Click 'Optimise' button
  16. When the optimise has finished, click OK
  17. Test

Historical Number

1042023

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Document information


More support for:

Cognos Consolidator
Consolidator

Software version:

6.22

Operating system(s):

Windows

Reference #:

1367433

Modified date:

2012-02-23

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