PDS-PCT-0023 and PDS-REC-0021 when accessing cubes

Technote (troubleshooting)


Problem(Abstract)

Intermittently on a distributed system, user encounters errors when accessing powercubes. Testing the cube datasource reveals failures from some dispatchers but not other. Restarting the dispatchers that are unable to connect allows connection.

Symptom

PDS-PCT-0023 PowerPlay Data Server cannot read the data cache.
PDS-REC-0021 (Open Data Cache)
PCA-ERR-0092 PPDS Failure: "ppdscgGetCubeFeatures" returns "3" for datasource "<cube name>".

Cause

Customer was using a third-party application (unblocker.exe) to remove file locks on the cube file so that they could copy new versions of the cube overtop of the existing. If the file locks are from active BIBus processes, breaking the file lock causes the associated datasource connections in that BIBus to become corrupt, causing this error whenever the system tries to reuse that session.

Environment

Windows

Resolving the problem

The methods for maintaining IBM Cognos Powerplay Cubes in a IBM Cognos 8 environment are descibed in the proven practice document Use of PowerCubes in Cognos 8. Use of other methods is not supported by IBM Cognos for Cognos 8.2.

Steps:Download and read the following document:

Related information

Use of PowerCubes in Cognos 8

Cross Reference information
Segment Product Component Platform Version Edition
Business Analytics Cognos 8 Business Intelligence Analysis Studio
Business Analytics Cognos 8 Business Intelligence Install and Config

Historical Number

1031486

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Document information


More support for:

Cognos 8 Business Intelligence
Install and Config

Software version:

8.2

Operating system(s):

Windows

Reference #:

1341741

Modified date:

2009-01-27

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