IBM Support

Sametime for IBM i: System Requirements

Technote (FAQ)


Question

What hardware and software is required to install and run Sametime on IBM i (i5/OS)?

Answer

IBM Sametime server requirements
Note: This document provides IBM i-specific information that should be used as a supplement to the "Detailed System Requirements for Sametime and Sametime Unified Telephony" (#7007792).

This document contains the following sections:

  • Sametime Server Hardware Requirements
  • Sametime 9.0.x Server Software Requirements
  • Sametime 8.5.x Server Software Requirements



Sametime Server Hardware Requirements

Use these values as general guidelines. The requirements for your environment may be different. For detailed server sizing, work with your IBM representative or Business Partner to submit a Techline request: http://www.ibm.com/partnerworld/wps/servlet/ContentHandler/LLIE-6LLS4T


    CPU:
      • Sametime 9.0.1 drops support of IBM i 6.1; add support of IBM i 7.3.
      • Sametime 9.0 drops support of IBM i 5.4
      • Sametime 9.0 HF1 supports IBM i 7.2
      • For WAS-based Sametime servers (Meeting, Proxy, System Console and Gateway): minimum of 3800 CPW on a POWER5 processor or higher.
      • For Sametime Community Server: systems with a minimum of 1500 CPW running a supported IBM i release. Systems with a CPW in the lower end of the acceptable range will likely require more than the stated minimum amount of memory
    RAM:
      • For WAS-based Sametime server (Meeting, Proxy, System Console and Gateway): minimum of 6GB memory.
      • Community Server: minimum 4GB memory plus 1GB for each additional Sametime and Domino server. 8GB is recommended. If server startup time is not satisfactory, consider increasing memory to 16GB.
    Disk:
      • For each WAS-based Sametime server (Meeting, Proxy, System Console and Gateway): 5GB free space recommended (3GB minimum) and a minimum of 6 disk drives with caching disk controller.
      • For Community Server servers: minimum 2GB free disk space for each Sametime server, 10GB recommended to allow for logs and tracing. Minimum of 4 disk drives.

Hardware Notes

-- For the Sametime 8.5.x Community Server and pre-8.5 Sametime servers, starting the server can stress your system if it has limited memory or a small number of disk drives (regardless of the size of your system processor). Paging rates increase dramatically during startup. Insufficient memory, fewer than 4 disk drives, or significant non-Sametime activity may prevent the Sametime server from starting due to internal timeouts. For more information about dealing with this situation, see "Sametime for IBM i: Common reasons for server not starting" (#1097835 ).

Additional Information

  • Details about compatible IBM i, Domino and Sametime releases is available in the Lotus Software for IBM i Compatibility Guide.
  • "Sametime for IBM i: What System Fixes are Required?" (#1089996 )
  • Refer to the document titled "i5/OS: Checking for installed software using iSeries Navigator or commands" (#1096619) for information about how to check for installed software.
  • Refer to the document titled "i5/OS : Checking for available hardware using iSeries Navigator or commands"(#1095869) for information about how to check for available hardware resources.


Sametime 9.x Server Software Requirements

Sametime 9.X Community Server (Domino-based)
Sametime 9.x System Console, Meeting, Proxy, and Gateway servers
(WebSphere-based)
Note: If upgrading from IBM i 5.4 or an earlier release to IBM i 6.1 or 7.1, see Lotus Domino planning for V6R1 for important information about Lotus Domino and related products, including Sametime.
  • Sametime 9.0 requires HF1 to support IBM i 7.2
  • Sametime 9.0.1 requires WebSphere Application Server Network Deployment 8.5.5.9 to support IBM i 7.3
More information about this release IBM Sametime
IBM Operating System
(IBM i)
ST 9.0.1:

5770SS1 (i 7.3, i 7.2,i 7.1)


Install Base SS1 plus:
- Option 12: Host servers
- Option 30: QShell Interpreter
- Option 34: Digital Certificate Manager (to use Secure Sockets Layer (SSL) protocol)
- Option 33: Portable Application Solutions Environment (PASE)
- Option 35: CCA Cryptographic Service Provider



ST 9.0:
5770SS1 (i 7.1, i 7.2), 5761SS1 (i 6.1)

Install Base SS1 plus:
- Option 12: Host servers
- Option 30: QShell Interpreter
- Option 34: Digital Certificate Manager (to use Secure Sockets Layer (SSL) protocol)
- Option 33: Portable Application Solutions Environment (PASE)
- Option 35: CCA Cryptographic Service Provider



Sametime 9.0 requires HF1 support IBM i 7.2
ST 9.0.1:

5770SS1 (i 7.3, i 7.2, i 7.1)


Install Base SS1 plus:
- Option 3: Extended Base Directory Support
- Option 12: Host servers
- Option 30: QShell Interpreter
- Option 33: Portable Application Solutions Environment (PASE)
- Option 34: Digital Certificate Manager (to use Secure Sockets Layer (SSL) protocol)
- Option 43: Additional Fonts (for Meeting Server)

ST 9.0
5770SS1 (i 7.1, i 7.2), 5761SS1 (i 6.1)

Install Base SS1 plus:
- Option 3: Extended Base Directory Support
- Option 12: Host servers
- Option 30: QShell Interpreter
- Option 33: Portable Application Solutions Environment (PASE)
- Option 34: Digital Certificate Manager (to use Secure Sockets Layer (SSL) protocol)
- Option 43: Additional Fonts (for Meeting Server)

Sametime 9.0 requires HF1 support IBM i 7.2
TCP/IP Connectivity Utilities ST 9.0.1:
5770TC1 (7.3,7.2 and 7.1)

ST 9.0:
5770TC1 (7.1, 7.2)
5761TC1 (6.1)
IBM Developer Kit for Java
ST 9.0.1:
5770JV1(7.3 and 7.2)
- Option 14:Java SE7 32bit
5761JV1 (7.1)
- Option 14:Java SE7 32bit

ST 9.0:
5761JV1 (7.1 and 6.1)
- Option 11: Java SE6 32bit

5770JV1 (7.2)
- Option 11: Java SE6 32bit
ST 9.0.1:
5770JV1 (7.3 and 7.2)
- Option 15:Java SE7 64bit
5761JV1 (7.1)
- Option 15:Java SE7 64bit

ST 9.0:
5761JV1 (7.1 and 6.1)
- Option 12: Java SE6 64bit

5770JV1 (7.2)
- Option 12: Java SE6 64bit
WebSphere Application Server for WAS Based server components N/A ST 9.0.1:
WebSphere Application Server Network Deployment 8.5.5.8
Sametime 9.0.1 require WebSphere Application Server Network Deployment on IBM i 7.3

ST 9.0 and 9.0 HF1:
WebSphere Application Server Network Deployment 8.5.5 and future fix packs
Domino for IBM i

For latest information on Domino updates, see
Domino Support
ST 9.0.1:
Domino 8.5.3 FP5, Domino 9.0, Domino 9.0.1

Domino9.0.1 FP6 is required for i 7.3

ST 9.0 HF1 : Domino 8.5.3 FP5 and later, Domino 9.0 and future fix packs

ST 9.0 : Domino 8.5.3 FP5 and later, Domino 9.0 and future fix packs
N/A
All required and recommended system fixes See "Sametime for IBM i: What System Fixes are Required?" #1089996
For languages other than English Recommend Domino Language Pack for language used by majority of your users

Note If Domino for IBM i language pack is not available for your preferred Sametime language, see "Sametime: Domino language pack unavailable for some supported languages" #1242066
N/A
For automatic conversion of Meeting Attachments Remote conversion server

Install and set up IBM Sametime Conversion Services on a Windows system. The remote conversion server can be installed with Sametime System Console

Integrated conversion services

Running conversion services as an integrated function of your Sametime Meeting server requires following options of the operating system (5770SS1 or 5761SS1):
- Option 33: Portable
Application Solutions Environment (PASE)
- Option 43: Additional Fonts


Sametime 8.5.x Server Software Requirements

Sametime 8.5.x Community Server (Domino-based)
Sametime 8.5.x System Console, Meeting, Proxy, and Gateway servers
(WebSphere-based)
Note: If upgrading from IBM i 5.4 or an earlier release to IBM i 6.1 or 7.1, see Lotus Domino planning for V6R1 for important information about Lotus Domino and related products, including Sametime.
More information about this release IBM Lotus Sametime
IBM Operating System
(IBM i)

Note i 6.1 or later required for Sametime IPv6 support.
ST 8.5.1 and 8.5.2:
5770SS1 (i 7.1), 5761SS1 (i 6.1) or
5722SS1 (i 5.4)

ST 8.5: 5761SS1 (i 6.1) or 5722SS1 (i 5.4)

Install Base SS1 plus:
- Option 12: Host servers
- Option 30: QShell Interpreter
- Option 34: Digital Certificate Manager (to use Secure Sockets Layer (SSL) protocol)
- Option 33: Portable Application Solutions Environment (PASE)
- Option 35: CCA Cryptographic Service Provider

ST 8.5.1 and 8.5.2:
5770SS1 (i 7.1), 5761SS1 (i 6.1) or 5722SS1 (i 5.4)

ST 8.5: 5761SS1 (i 6.1) or 5722SS1 (i 5.4)

Install Base SS1 plus:
- Option 3: Extended Base Directory Support
- Option 12: Host servers
- Option 30: QShell Interpreter
- Option 33: Portable Application Solutions Environment (PASE)
- Option 34: Digital Certificate Manager (to use Secure Sockets Layer (SSL) protocol)
- Option 43: Additional Fonts (for Meeting Server)
TCP/IP Connectivity Utilities 5770TC1 (7.1)
5761TC1 (6.1)
5722TC1 (5.4)
IBM Developer Kit for Java

Note When installing a new option of 5722JV1 for the first time, you must reinstall the recommended Java Group PTF. See #1089996

5761JV1 (7.1 and 6.1)
- Option 11: Java SE6 32bit

or 5722JV1 (5.4) Base plus
- Option 8: J2SE 5.0 32bit
5761JV1 (7.1 and 6.1)
- Option 11: Java SE6 32bit

or 5722JV1 (5.4) Base plus
- Option 11: J2SE 6.0 32-bit JVM
Domino for IBM i

For latest information on Domino updates, see
Domino Support
ST 8.5.2 IFR1: Domino 8.5.3, 8.5.2, 8.5.1, 8.5, or 8.0.x

ST 8.5.1 and 8.5.2: Domino 8.5.2, 8.5.1, 8.5, or 8.0.x

ST 8.5: Domino 8.5.1*, 8.5, or 8.0.x

Domino 8.5.x (5733L85)
Domino 8.0.x (5733LD8)

* ST 8.5 was not certified with Domino 8.5.1 prior to general availability but this environment is supported.
N/A
All required and recommended system fixes See "Sametime for IBM i: What System Fixes are Required?" #1089996
For languages other than English Recommend Domino Language Pack for language used by majority of your users

Note If Domino for IBM i language pack is not available for your preferred Sametime language, see "Sametime: Domino language pack unavailable for some supported languages" #1242066
N/A
For automatic conversion of Meeting Attachments Meetings hosted on Sametime Community Server

Remote conversion server

Install and set up Lotus Sametime Conversion Services on a Windows system. Sametime Conversion Services is available on the Sametime Community Server DVD or webkit.

Integrated conversion services

Running conversion services as an integrated function of your Sametime Community server requires following options of the operating system (5722SS1 or 5761SS1):
- Option 33: Portable Application Solutions Environment (PASE)
- Option 43: Additional Fonts

N/A

Related information

i5/OS: Checking for installed software using iSeries Na
i5/OS : Checking for available hardware using iSeries N
What System Fixes are Required?
Detailed Sametime System Requirements

Historical Number

189160

Document information

More support for: IBM Sametime
Install/Configuration

Software version: 8.5, 8.5.1, 8.5.2, 9.0, 9.0.1

Operating system(s): IBM i

Reference #: 1092193

Modified date: 2015-09-17