IBM Support

Failure attempting to load GSK library SSL0166E when using SSL with IBM HTTP Server

Troubleshooting


Problem

You are unable to use SSL with the IBM HTTP Server after a new installation. Your website cannot be used for SSL communications although the installation log (log.txt) for the IBM HTTP Server shows that IBM HTTP Server and GSKit was installed successfully.

Symptom

After you start the server, the following error is received in the IBM HTTP Server error.log file:
[notice] (20019)DSO load failed: SSL0166E:
Failure attempting to load GSK library (libgsk7ssl.so) Configuration
Failed

Cause

Not all of the Linux packages had been installed according to the product prerequisites. Missing library packages will cause GSKit not to load properly.

Environment

All Linux operating systems are affected.

Resolving The Problem

The following WebSphere Application Server Knowledge Center page has details on the library packages that are required for each Linux distribution: Preparing Linux systems for installation.

On step 11, select the hyperlink for the Linux distribution being used. There will be a list of required library packages to install. Compare your operating system's current list of packages to this list and install any missing packages. Ensure that you have applied BOTH 32 bit and 64 bit packages where applicable.

[{"Product":{"code":"SSEQTJ","label":"IBM HTTP Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Runtime","Platform":[{"code":"PF016","label":"Linux"}],"Version":"8.5.5;8.5;8.0;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
07 September 2022

UID

swg21451021