IBM Support

Error opening Analyst: "Analyst Server failed to start because it was unable to locate the Filesys.ini file"

Troubleshooting


Problem

Unable to open Analyst or/and access Contributor applications

Symptom

The following error is displayed when trying to open Analyst or/and access Contributor applications :
"Analyst Server failed to start because it was unable to locate the Filesys.ini file:
\\<servername>\<parent_directory>\bin\Filesys.ini>"

Cause

The Main section in the beginning of Filesys.ini is missing or not correct.

Diagnosing The Problem

Filesys.ini path is correct / reachable and the user have full control on the folder.

Resolving The Problem

Modify the filesys.ini in order to have the [Main] section first, at least the 7 lines below and before any libraries references :
[Main]
Libs=C:\Program Files\cognos\c8\bin\LIBS.TAB
MaxUsers=5
Locks=C:\Program Files\cognos\c8\bin\Locks\locks.log
Logins=C:\Program Files\cognos\c8\bin\Locks\logins.log
UGR=C:\Program Files\cognos\c8\bin\UGR.TAB
Padlocks=C:\Program Files\cognos\c8\bin\PADLOCKS.TAB

You can also copy the file from another valid installation.

Related Information

[{"Product":{"code":"SS9S5U","label":"Cognos 8 Planning"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Analyst","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4.1;8.4;8.3;8.2;8.1;10.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21502236