Troubleshooting
Problem
Large log files and dumps can accumulate over time. These should be cleaned up to save disk space, and also to reduce the size of 'service' packages for support.
Symptom
Very large service zip packages
Cause
Normal product operation
Environment
SC (Spectrum Control)/TPC servers running on Windows, AIX, Linux
Diagnosing The Problem
Running the SC/TPC 'service.bat' or 'service.sh' command takes a long time, and the resulting zip file is very large (500mb+).
Resolving The Problem
Refer to these instructions to clean up your TPC server directory before using the 'service.bat' or 'service.sh' commands:
on windows, <tpc> = C:\Program Files\IBM\TPC (drive may be different)
on unix, <tpc> = /opt/IBM/TPC
General guidelines:
- old files may be deleted (or moved to a compressed folder outside of <tpc>)
- if any large files have current date/time, you may want to keep the newest copy
- when deleting large log files, do not delete the newest/current file being written
- you can use the 'Search' option in Windows explorer, or the unix 'find' command to search for large files (e.g.: find /opt/IBM/TPC -size +50M -print)
1. Delete the following old/large files (if they exist) from:
TPC 5.x: <tpc>/wlp/usr/servers/deviceServer/...
<tpc>/ewas/profiles/WebServerProfile/...
and
<tpc>/data/... or /log/...
*tpcdump*
*heapdump*
tpc_heapdump*
javacore*
2. Search for and delete any old/large log files in these directories and their subdirectories:
TPC 5.x: <tpc>/ewas/profiles/WebServerProfile/logs/webServer/...
(typical are SystemErr* and SystemOut* files)
<tpc>/device/log/...
(typical are msgTPCDeviceServerX.log, traceTPCDeviceServerX.log/.trace, tracePerfMgrX.log/.trace)
<tpc>/data/log/...
Related Information
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Document Information
Modified date:
22 February 2022
UID
swg21458081