IBM Support

CCRC login results in "The server cannot be contacted" error

Troubleshooting


Problem

Attempts to log on to the CM Server from an IBM Rational ClearCase Remote Client (CCRC) results in the error "The server cannot be contacted. Please contact your system administrator".

Symptom

Cause

There are various possible causes for this issue which include the following:


Diagnosing The Problem

Additional Troubleshooting tips:

  • Verify that the problem is not caused by an authentication issue as described in
    technote 1226161
    Unable to authenticate using PAM from CCWeb, MSWeb or CCRC clients

  • Check the CM server logs for errors reporting memory allocation issues.
    To verify this check the CM server system log found at:

    Default path Unix: /opt/rational/common/CM/profiles/cmprofile/logs

    Example: /opt/rational/common/CM/profiles/cmprofile/logs/server1
    /SystemOut.log


    Default path Windows:

    C:\Program Files\IBM\RationalSDLC\common\CM\profiles\cmprofile\logs

    Example:
    C:\Program Files\IBM\RationalSDLC\common\CM\profiles\cmprofile\logs\server1\SystemOut.log

    Here is a snippet from this log when the CM server does not have enough memory available:
  • ----------------------cut--------------------


    Caused by: com.ibm.rational.stp.server.oncrpc.OncrpcServer$StartupException: CRVSV0202E Unable to start server: ccrpc.sh: java.io.IOException: Cannot
    allocate memory at com.ibm.rational.stp.server.oncrpc.OncrpcManagedConnectionFactory$Base
    Server$StartServerAction.run(OncrpcManagedConnectionFactory.java:2937)
    at java.security.AccessController.doPrivileged(AccessController.java:246)

    ----------------------cut--------------------

    For Cause 7


    The following error will be seen in the logs (note that the first entry actually shows the login of the failing user as having succeeded, even with the failure):

    [4/2/10 21:26:46:125 EDT] 00000024 CMLogger      I com.ibm.rational.stp.server.cc.CcProxy doLogin CRVSV0900I ClearCase login of user 'DOMAIN\test' onto server 'ClearCase - 2.7428' succeeded.                                                                  

    [4/2/10 21:26:55:125 EDT] 00000027 CMLogger      W com.ibm.rational.stp.server.oncrpc.OncrpcManagedConnectionFactory
    $BaseServer testIfDied          

    CRVSV0212I Initiated cleanup of failed backend ONC RPC server ID: ClearCase - 2.7428  


    Running a tool like Process Monitor will also clearly show ACCESS DENIED errors when attempting to write to the temp location.

Resolving The Problem

Solution for Cause 1

Move the path to the common directory toward the beginning of the variable.


This can be done from the GUI:
  1. Right-click My Computer
  2. Choose Properties
  3. Select the Advanced tab
  4. Choose Environment Variables at the bottom of the window
  5. Modify the PATH variable such that C:\Program Files\IBM\RationalSDLC\common is towards the beginning of the path.
  6. After that change is made, type set in the command prompt to verify the change is correct. It should look similar to this:

    Path="C:\Program Files\IBM\RationalSDLC\ClearCase\bin";"C:\Program Files\IBM\RationalSDLC\common";"C:\Program Files\IBM\RationalSDLC\clearcase\etc\utils";C:\WINDOWS\system32;C:\;C:
    \WINDOWS...


Solution for Cause 2

Add more memory to the CM server.


Solution for Cause 3

Use the correct form of the team URL as described in technote 1329952: About the Web Server URL for CCRC 7.1. For example:

http://myserver/TeamWeb/services/Team
or http://myserver:12080/TeamWeb/services/Team



Note: The URL http://hostname:12080/TeamWeb/services/Team is case sensitive.




Solution for Cause 4

Review technote 1403562: Windows 2008 64 Bit CM Servers fail logins when CCRC clients have primary group preference enabled for additional details about APAR PK91671.


Solution for Cause 5

Ensure that the ClearCase license files exist and contain correct information.


Check for the /var/adm/rational/clearcase/config/flexlm_host
file to see if it exists and has the correct contents.

If ATRIA licenses are being used, check to see if the license.db file exists and contains the license keys.
Also, check for the existence of the /var/adm/rational/clearcase/config/license_host file which should contain the hostname of the license server.




Solution for Cause 6

Move the user region map file (and change the path value in the ccrcUserRegionMapfile mBean) to a common area. Avoid storing it in IBM Application directories as those could be modified or removed during upgrades/installations.

For the error "CRVAP0220E Conflict error":
Add the default mapping.



Solution for Cause 7

Ensure that the CCRC temp directory is writable by all users who will be logging on remotely.


Note: CM Server will try to write to the following locations for temp storage (in this order):
  • Location specified by ccrcTempDir mbean value.
  • Location specified by TEMP environment variable (generally the system TEMP location will be used, unless the WAS service is running under different credentials -- in which case, that user's TEMP variable location will be used instead).
  • On Windows, the root of the C: drive.



Solution for Cause 8

Review technote 1224586: System Requirements for the ClearCase Remote Client for information about client and server requirements.



Solution for Cause 9

Move the file to another location to free disk space and restart the server.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ClearCase Remote Client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.0.1;7.1.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21373322