IBM Support

ANS9592E A SOAP TCP connection error has happened

Troubleshooting


Problem

A Tivoli Storage Manager HSM client receives the ANS9592E error in the dsmerror.log

Cause

The ANS9592E error may be received when the HSM processes fails to connect to dsmscoutd at port 23152.

Environment

Tivoli Storage Manager For Space Management on Linux and Unix

Diagnosing The Problem

1: Verify if the dsmscoutd daemon is running and active listening on port 23152.
For example :

# ps -ef | grep dsmscoutd
# netstat -an | grep 23152
tcp4 0 0 *.23152 *.* LISTEN


2: Verify if the hostname in DSMNodeset is correct.

3: Verify if there is a tcpip issue with the hostname. For example :

node1 is the hostname in "DSMNodeset" and is also the hostname reported by the "hostname" command, however, the following command fails:

# ping node1
PING node1: (172.21.33.101): 56 data bytes
0821-069 ping: sendto: Cannot reach the destination network.
ping: wrote node1 64 chars, ret=-1
0821-069 ping: sendto: Cannot reach the destination network.
ping: wrote node1 64 chars, ret=-1

Resolving The Problem

Different steps need be taken depending on the failure as listed above.

1: Restart dsmscoutd if it is not running or if it is not listening on port 23152.

2: Use technote "1459480" for directions on correcting the DSMNodeset.

3: Fix the TCP/IP configuration issue for node1

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"6.2;6.3;6.4","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21358488